待验证50% 置信事实精确时间
npm 安装依赖时会将满足版本范围的包尽量提升到 node_modules 顶层以复用;版本范围不重叠时会嵌套安装多份副本,可能导致运行时加载的版本与预期不符。
1
来源数
50%
置信度
长期有效
时效性
2026/10/24
首次发现
来源
涉及实体
相关事实
待验证只有上层依赖包同步发布更新,最终用户才能通过 npm update 命令获得上游底层包的修复73% 相似待验证在 npm 生态中,^2.0.0 这样的依赖范围允许自动升级到任意 2.x.y 版本,patch 发布通常会被下游项目在安装时无感拉取73% 相似待验证npm update 在非 workspaces 项目中默认只更新直接依赖,间接依赖需要额外的 --depth 参数或手动介入70% 相似已验证在 npm 生态中,^3.0.25 这类范围声明会自动接受补丁与次版本升级,执行 npm update 时会自动获取 3.0.2669% 相似待验证当项目中多个 provider 包依赖不同版本的 provider-utils 时,npm 可能会安装多份副本,导致类型不匹配或运行时行为不一致66% 相似
引用此条事实
Stable URI
https://kongchang.com/claim/1094161API
curl https://kongchang.com/api/v1/knowledge/claims/1094161MCP
get_claim(id=1094161)